changelogs.md


akbkk/create-react-app

Repository  -  API  -  Source

1.0.0

May 18, 2017

We’ve been working on this release for the past few months, and there are many big impovements, from migrating to webpack 2 to a brand new runtime error overlay and built-in support for Progressive Web Apps.

So instead of just enumerating them here, we decided to write a blog post about all the new features.
Check it out: What’s New in Create React App.

Have you read it? Now let's see how to update your app to the latest version.

0.9.5

First, ensure you are using the latest Node 6 LTS or newer. In 1.0.0, we have dropped support for Node 4 and NPM 2.

Inside any created project that has not been ejected, run:

npm install --save-dev --save-exact react-scripts@1.0.0

You may also optionally update the global command-line utility for bug fixes:

npm install -g create-react-app

Ensure application and test files reside in src/

We've never supported importing files from outside src/, nor have we supported running tests outside of src/.
We also never explicitly forbid doing so, which caused confusion when things didn't work like they should.

When running or building your application, you may see a message like so:

You attempted to import ... which falls outside of the project src/ directory.

To remedy this, simply move any files that you import within src/ and update your relative imports accordingly. This enforces that files that import each other stay in src/, and other folders serve different purposes (e.g. the public/ folder just gets served from the root).

If you used relative imports outside the project directory as a way to share code with another project, consider using a monorepo instead, so that other projects are symlinked to your project's node_modules/. Then you can import them as a Node modules.

While running npm test, you may notice some of your tests are missing. Please move any top-level test directory (i.e. __test__, __spec__) or files (i.e. *.test.js, *.spec.js) into src/. Conversely, if you have some similarly named files that you don’t want Jest to run, move them outside of src/.

Import required locales for Moment.js

Moment.js locales are now purposely excluded from the bundle unless explicitly depended on.

Please import the locales you need:

import moment from 'moment';
import 'moment/locale/fr';
import 'moment/locale/es';

You can no longer import file content

You can no longer import a file and expect to receive its contents as an encoded string.
This behavior was confusing and inconsistent depending on the file size.

Importing files with unknown extensions will now always include them into the build and return a valid URL.

If you'd like to import a file's contents as a string, consider contributing to #1944. For the time being, you must embed assets within an export:

// sample.txt
export default `i want
this data as a string
`;

You can then import this as so:

import sampleText from './sample.txt';

// ...

Confusing window globals can no longer be used without window qualifier

Please prefix any global method with window., you may experience this with methods such as confirm.

Simply update references from confirm to window.confirm.

Note that this new lint error will likely uncover legitimate accidental uses of global variables where you meant to define a local variable instead.

Why is my import erroring out?

You can no longer use AMD import syntax, nor define an import anywhere other than the top of the file.

This is to reduce confusion around import statements, which do not allow you to evaluate code between them.

I see many accessibility warnings

We have enabled a new set of rules to help make applications more accessible, please take time to learn about the errors and fix them.

You can search for every lint rule name in the right column and read its description on the web. The fixes are usually very simple.

I see many warnings about PropTypes and createClass

We have enabled the lint warnings about React APIs deprecated in React 15.5. You can automatically convert your project to fix them by running the corresponding codemods.

How do I make my tests work with Jest 20?

Please refer to the Jest 19 and Jest 20 breaking changes for migration instructions.

If you use snapshots, you will likely need to update them once because of the change in format.

Flexbox 2009 spec is no longer polyfilled

The old, 2009 specification for Flexbox is deprecated and is 2.3x slower than the latest specification.

We are no longer polyfilling it automatically.

How to turn my app into a Progressive Web App?

After the regular update procedure above, add these line to <head> in public/index.html:

    <meta name="theme-color" content="#000000">
    <!--
      manifest.json provides metadata used when your web app is added to the
      homescreen on Android. See https://developers.google.com/web/fundamentals/engage-and-retain/web-app-manifest/
    -->
    <link rel="manifest" href="%PUBLIC_URL%/manifest.json">

Then create a file called public/manifest.json that looks like this:

{
  "short_name": "React App",
  "name": "Create React App Sample",
  "icons": [
    {
      "src": "favicon.ico",
      "sizes": "192x192",
      "type": "image/png"
    }
  ],
  "start_url": "./index.html",
  "display": "standalone",
  "theme_color": "#000000",
  "background_color": "#ffffff"
}

Finally, create src/registerServiceWorker.js with this template, import it from src/index.js and call the function it exports.

Anything missing?

This was a large release, and we might have missed something.

Please file an issue and we will try to help.

Detailed Changelog

For a readable summary of the changes, check out our blog post.

:boom: Breaking Change

  • react-dev-utils, react-scripts
    • #2189 Add ModuleScopePlugin to ensure files reside in src/. (@Timer)
  • react-scripts
  • eslint-config-react-app, react-dev-utils
  • eslint-config-react-app, react-error-overlay, react-scripts
  • eslint-config-react-app, react-scripts

:rocket: New Feature

  • react-scripts
  • react-dev-utils, react-scripts
    • #1101 Add react-error-overlay, our new crash overlay. (@Timer)
    • #1590 Support specifying a node script as BROWSER environment variable. (@GAumala)
    • #1790 Support multiple proxies in development. (@jamesblight)
  • eslint-config-react-app, react-scripts

:bug: Bug Fix

:nail_care: Enhancement

:memo: Documentation

:house: Internal

Committers: 66

Releases Before 0.x

Please refer to CHANGELOG-0.x.md for earlier versions.