changelogs.md


blond/eslint-config-pedant

Repository  -  API  -  Source

1.0.0

November 2, 2017

Dependencies

  • Requires an ESLint of at least v4.2.0 (@blond #67).
  • Droped support for ESLint v3 (@blond #67).

Common Rules

ES5 & ES2015 Rules

Bug Fixes

Documentation

  • Updated preset section for es2015 (@jt3k #60).

0.10.0

July 2, 2017
  • Supported ESLint 4 (@blond [#55]).

0.9.0

April 22, 2017

Common Rules

ES2015 Rules

Other

  • Renamed the es6 preset to es2015 (@blond #50).

0.8.1

April 9, 2017

Rules

Documentation

0.8.0

September 3, 2016

Rules

Dependencies

  • Requires an eslint of at least v3.3.0.

0.7.0

July 8, 2016

Support Node.js

  • Drop support for Node.js < 4. (ESLint dropped support in v3.0.0).

Commits

  • [a7917f2] - chore(travis): run tests in Node.js 6 (@blond)
  • [7ded85c] - chore(node): drop support for Node.js < 4 (@blond)

0.6.0

June 2, 2016

Dependencies

  • eslint updated to 3.0.0
  • es6-object-assign updated to 1.0.2

Commits

  • [306e379] - Update eslint to ^3.0.0 (@tadatuta)
  • [be5884c] - chore(package): update es6-object-assign to version 1.0.2 (@greenkeeperio-bot)

0.5.0

May 15, 2016

ECMAScript 3 & 5

Added shareable configs for ECMAScript 3 and ECMAScript 5 (#16, #19).

Read more in ECMAScript section.

Rules

Removed comma-dangle rule for es6 and es5 configs (#14, #19).

Dependencies

Now eslint-config-pedant requires eslint version 2.9.0 or more (#20).

Commits

  • [1ec3a8a] - chore(package): specify eslint as peer dependency (@blond)
  • [7fc57d2] - docs: add section about ECMAScript versions (@blond)
  • [883ea5b] - docs(example): separate example for es3 (@blond)
  • [f1e985a] - feat: add sub configs for es3, es5 and es6 (@blond)
  • [4a67e81] - chore(package): update eslint to version 2.10.1 (@greenkeeperio-bot)

0.4.0

May 5, 2016

Rules

Commits

  • [75f4c00] - docs: add example for no-unsafe-finally rule (@blond)
  • [e3999c0] - feat: add no-unsafe-finally rule (@blond)
  • [30e9caa] - docs: update question about stylistic rules (@blond)
  • [a70ed61] - chore(package): update eslint to version 2.9.0 (@greenkeeperio-bot)
  • [43b454d] - chore(package): update eslint to version 2.8.0 (@greenkeeperio-bot)

0.3.0

April 12, 2016

Rules

Added ES 2015 rules:

Commits

  • [f802a06] - examples: add examples for es6 rules (blond)
  • [9baed36] - rules: add es6 rules (blond)

0.2.0

March 8, 2016

Rules

Commits

  • [938f82e] - update npm scripts (@blond)
  • [b8add01] - npm: update keywords (@blond)
  • [9cfe57c] - examples: add example for no-new-requir rule (@blond)
  • [8d43a72] - rules: add no-new-require rule (@blond)
  • [2cbcb02] - examples: remove no-undefined rule (@blond)
  • [904bc94] - examples: fix comma-dangle rule (@blond)
  • [929c79c] - docs: fix to no-undefined rule in bad examples (@guria)
  • [8f27afc] - chore(package): update eslint to version 2.7.0 (@greenkeeperio-bot)
  • [13f4aed] - chore(package): update eslint to version 2.6.0 (@greenkeeperio-bot)
  • [1acc399] - chore(package): update eslint to version 2.5.3 (@greenkeeperio-bot)
  • [40c3dbe] - docs(install): update install guide (@blond)