changelogs.md


brainsiq/hapi-boom-decorators

Repository  -  API  -  Source

4.1.2

November 4, 2018

Changed

  • Update boom to version 7.2.2

4.1.1

July 25, 2018

Security

  • Update boom sub-dependencies to remove vulnerable version of hoek (CVE-2018-3728)

4.1.0

April 7, 2018

Added

  • Decorator function for Boom.failedDependency

Changed

  • Tested against hapi.js v17.4.0

4.0.0

December 4, 2018

Added

  • Support for hapi.js version 17 and Boom version 7
  • Decorator function for Boom.boomify

Removed

  • Support for hapi.js versions older than 17 and Node.js versions 4, 6 and 7
  • wrap and create decorator functions (use boomify instead)

3.0.1

November 11, 2017
  • Updated docs with Hapi v17 information

3.0.0

May 29, 2017

Changed

  • Updated boom dependency to version 5.1.0

2.3.0

April 19, 2017

Added

  • Support for Boom.teapot()

2.2.2

December 4, 2016

Changed

  • Regenerated npm-shrinkwrap.json to remove development dependencies

2.2.1

December 4, 2016

Fixed

  • Remove spread operator usage to fix Node 4 support #39
  • Add node 4 back to CI configuration

2.2.0

December 3, 2016

Fixed

  • Support creating boom errors with a function signature that is not Boom.[errorType]([message], [data])

e.g. Boom.methodNotAllowed([message], [data], [allow])

2.1.1

December 3, 2016

Changed

  • Test against latest versions of node 6 and 7
  • Update dependencies
  • Remove retire.js and test with Snyk

2.1.0

October 7, 2016

Changed

  • Test against latest versions of node 4, 5 and 6
  • Update boom dependency

Added

  • Decorate hapi.js reply interface with new boom functions: internal, paymentRequired

2.0.2

September 1, 2016

Changed

  • Test against latest hapi version 15
  • Update dependencies
  • Test against latest versions of node 5 and 6

2.0.1

August 14, 2016

Changed

  • Test against latest hapi version 14
  • Update dev dependencies (inc changing XO -> JS Standard)

2.0.0

July 14, 2016

Changed

  • Update Boom dependency
  • Replace serverTimeout function with serverUnavailable

1.1.4

July 14, 2016

Changed

  • Update out of date dependencies (exc. Boom)
  • Test only in latest few versions of node 4.x, 5.x and 6.x

1.1.3

March 19, 2016

Changed

  • Test against hapi version 13
  • Update out of date dependencies
  • Test against additional node 4.x and 5.x versions

1.1.2

January 10, 2016

Changed

  • Test against hapi version 12
  • Test against additional node version 5.4

1.1.1

January 3, 2016

Changed

  • Fix peer dependency conflicts with dev dependencies and build issues
  • Specify minimum node version in package.json

1.1.0

December 27, 2015

Added

  • reply.illegal() decorated function for new 451 HTTP response code

Changed

  • Test against additional node versions (5.2 and 5.3)