changelogs.md


collectiveidea/interactor-rails

Repository  -  API  -  Source

2.2.0

September 1, 2019
  • [ENHANCEMENT] Add support for Ruby 2.6
  • [ENHANCEMENT] Add support for Rails 6.0+

2.2.0

April 23, 2018
  • [ENHANCEMENT] Add support for Ruby 2.5
  • [ENHANCEMENT] Drop support for EOL Ruby version 2.2
  • [ENHANCEMENT] Add support for Rails 5.2

2.1.1

May 9, 2017
  • [BUGFIX] Properly constrain the gemspec's Rails version requirement

2.1.0

May 9, 2017
  • [FEATURE] Add spec templates
  • [ENHANCEMENT] Add support for Ruby 2.4
  • [ENHANCEMENT] Drop support for EOL Ruby versions 1.9.3, 2.0, and 2.1
  • [ENHANCEMENT] Add support for Rails 5.1
  • [ENHANCEMENT] Drop support for EOL Rails versions 3.0, 3.1, 3.2, 4.0, and 4.1

2.0.2

March 18, 2016
  • [ENHANCEMENT] Add support for Ruby versions 2.1, 2.2, and 2.3
  • [ENHANCEMENT] Add support for Rails versions 4.1, 4.2, and 5.0 (beta)

2.0.1

September 8, 2014
  • [BUGFIX] Generate nested directories for generated namespaced interactors

2.0.0

September 8, 2014
  • [ENHANCEMENT] Update to be play nice with Interactor 3.0

1.0.1

August 19, 2013
  • [ENHANCEMENT] Open up the interactor dependency version requirement
  • [BUGFIX] Require interactor
  • [ENHANCEMENT] Remove the Interactor::Rails module

1.0.0

August 17, 2013
  • Initial release!