changelogs.md


maxsolovev/postcss-import-with-aliases

Repository  -  API  -  Source

11.1.0

February 10, 2018
  • Added: filter option

11.0.0

September 16, 2017
  • Changed: A syntax error in an imported file now throws an error instead of just warning (#264)
  • Changed: Symlink handling to be consistent with Node.js require (#300)

10.0.0

May 12, 2017
  • Removed: Support for Node.js versions less than 4.5.x (#283)
  • Changed: Upgraded to Postcss v6 (#283)
  • Removed: jspm support (#283)
  • Removed: deprecated addDependencyTo option
  • Removed: onImport option
  • Changed: Doesn't depend on promise-each (#281)

9.1.0

January 10, 2017
  • Added: addModulesDirectories option (#256)

9.0.0

December 2, 2016
  • Removed: transform option (#250)
  • Removed: pkg-resolve is no longer a dependency; this should fix some issues with webpack. jspm users must manually install pkg-resolve if they want to load jspm modules (see https://github.com/postcss/postcss-import#jspm-usage for more info) (#243)
  • Changed: If a file is not found, it will now throw an error instead of just raising a warning (#247)
  • Changed: If a custom resolver does not return an absolute path, the default resolver will be applied to the returned path. (#249)
  • Changed: postcss-import will try to guess the correct parser for imported files, based on the file extension. (#245)
  • Changed: Deprecated addDependencyTo option, it is not needed if using postcss-loader >= v1.0.0 (#251)

8.2.0

November 9, 2016
  • Fixed: Warn about all @imports after other CSS declarations (#240)
  • Added: dependency message (#241)

8.1.3

November 3, 2016
  • Fixed: Nested import ordering (#236 - @RyanZim)

8.1.2

May 7, 2016
  • Fixed: prevent JSPM to throw unrecoverable error (#205)

8.1.1

May 4, 2016
  • Fixed: JSPM support (#194)

8.1.0

April 4, 2016
  • Added: JSPM browser field (#186)

8.0.2

January 27, 2015
  • Fixed: Comments between imports statements are ignored (#164)

8.0.1

January 27, 2015
  • Fixed: missing "lib" folder (#161)

8.0.0

January 27, 2015

All imports statements must be at the top of your file now, per CSS specification.
You should use postcss-reporter to see the warnings raised.

  • Removed: async mode/option (now async by default) (#107)
  • Removed: "bower_components" not supported by default anymore, use "path" option to add it back
  • Removed: encoding option. Encoding can be specified in custom load option
postcssImport({
  load: function(filename) {
    return fs.readFileSync(filename, "utf-8")
  }
})

(#144)

  • Removed: glob support (#146)

Globs can be implemented with custom resolve option

postcssImport({
  resolve: function(id, base) {
    return glob.sync(path.join(base, id))
  }
})

(#116)

  • Changed: custom resolve has more responsibility for paths resolving. See resolve option for more information about this change (#116)
  • Changed: support promise in transform option and undefined result will be skipped (#147)
  • Changed: options.plugins are applied to unprocessed ast before imports detecting (157)
  • Added: custom resolve function can return array of paths (#120)
  • Added: custom syntax in imported files support (#130)
  • Added: support custom load option (#144)
  • Added: detect css extension in package.json main field (153)

Note: If you miss options/default behavior (glob etc), a new plugin will handle all those things. Please follow issue #145

7.1.3

November 5, 2015
  • Fixed: ensure node 0.12 compatibility, round 2 (#93)

7.1.2

November 5, 2015
  • Fixed: performance issue because of cloned options (#90)

7.1.1

November 5, 2015
  • Added: ensure node 0.12 compatibility

7.0.0

August 25, 2015
  • Removed: compatibility with postcss v4.x (#75)
  • Added: compatibility with postcss v5.x (#76)
  • Added: lighter package by upgrading some dependencies (#73)

6.2.0

July 21, 2015
  • Added: skipDuplicates option now allows you to not skip duplicated files (#67)

6.1.1

July 7, 2015
  • Fixed: Prevent mutability issue, round 2 (#44)
  • Added: plugins option, to run some postcss plugin on imported files (#55)
  • Added: bower_components is now part of the default paths (#66)
  • Added: async option allow to use enable PostCSS async API usage. Note that it's not enabling async fs read yet. It has been added to fix breaking change introduced by 6.1.0.

6.1.0

July 7, 2015

This release was not respecting semver and introduced a major breaking change. It has been unpublished for now.

6.0.0

June 17, 2015
  • Changed: warnings messages are now using postcss message api (4.1.x)
  • Added: warning when a import statement has not been closed correctly (#42)

5.2.2

April 19, 2015
  • Fixed: globbed imports work for module directories (#37)

5.2.1

April 17, 2015
  • Fixed: glob import now works with single quote @import (#36)

5.2.0

April 15, 2015
  • Added: glob pattern are now supported if glob option is set to true (#34)
  • Added: plugin can now be added to PostCSS without calling it as a function (#27)

5.1.1

April 10, 2015
  • Fixed: regression of 5.1.0: files which only contain same @import rules were skip (#31)

5.1.0

March 27, 2015
  • Added: files with the same content will only be imported once. Previously, only the full path was used to determine if a file has already been imported in a given scope. Now, we also test create a hash with the content of the file to check if a file with the same content has not already been imported. This might be usefull if some modules you import are importing the same library from different places (eg: normalize might be as dep for several modules located in different places in node_modules) (#29)

5.0.3

February 16, 2015
  • Fixed: regression of 5.0.2: AST parent references were not updated (#25)

5.0.2

February 14, 2015
  • Fixed: indentation and code style are now preserved (#20)

5.0.1

February 13, 2015
  • Fixed: breaking bug with remote stylesheets (#21 & #22)

5.0.0

January 26, 2015
  • Added: compatibility with postcss v4.x
  • Removed: compatibility with postcss v3.x
  • Fixed: relative imports (./ and ../) should work using path option only (no need for from) (#14)

4.1.1

January 5, 2015
  • Fixed: irregular whitespace that throw syntax error in some environnements

4.1.0

December 12, 2014
  • Added: web_modules is now in module directories that are used to resolve @import (#13).

4.0.0

December 11, 2014
  • Added: windows compatibility (by building on AppVeyor)
  • Added: root option

3.2.0

November 24, 2014
  • Added: onImport callback offers a way to get list of imported files (ref)

3.1.0

November 24, 2014
  • Added: ability to consume local modules (fix #12)

3.0.0

November 21, 2014
  • Added: ability to consume node modules (ref). This means you don't have to add node_modules in the path anymore (or using @import "../node_modules/..."). Also, index.css can be ommited.

This means something like this

@import "../node_modules/my-css-on-npm/index.css";

can be written like this

@import "my-css-on-npm";

Dependencies of dependencies should be resolved as well.

Note that npm resolution is done after the default local behavior.

  • Changed: When importing a file multiple times in the same scope (same level of media queries), file will only be imported the first time. This is done to avoid having multiples outputs of a npm dep used multiples times in different modules.

2.0.0

November 12, 2014
  • Added: compatibility with postcss v3.x
  • Removed: compatibility with postcss v2.x

1.0.3

October 29, 2014
  • Fixed: relative import path stack

1.0.2

September 16, 2014
  • Added: Move ignored import at top & adjust related media queries, to make them work (fix #2)
  • Added: Ignore scheme-relative absolute URLs
  • Removed: parse-import module dependency

1.0.1

August 26, 2014
  • Fixed: GNU message format
  • Added: Support empty files (cssnext/#24)

1.0.0

August 10, 2014

✨ First release based on rework-import v1.2.0 (mainly for fixtures)