changelogs.md


shakacode/bootstrap-loader

Repository  -  API  -  Source

3.0.3

March 27, 2019

Fixed

  • Upgraded dependencies for security advisories. PR 365 by alecf.

3.0.2

October 31, 2018

Fixed

  • Make work with sass-resources-loader. sass-resources-loader imports specified SASS files load into every SASS file bootstrap-loader processes. PR 357 by x-yuri.

3.0.1

August 14, 2017

Improved

  • Env specific settings will override default settings. PR 356 by justin808.

3.0.0

May 11, 2017

Updated

  • Update to Webpack 4: extract-text-webpack-plugin is replaced with mini-css-extract-plugin. — Update basic & css-modules examples.

2.2.0

August 14, 2017

Updated

  • Replaced support for Bootstrap 4.0.0-alpha.6 with 4.0.0-beta. #299 by Ivan Kalinin.
  • Removed useFlexbox option since BS4 uses flexboxes by default
  • Removed normalize option from your bootstrap v4 config. It was dropped in beta.
  • Updated dependencies in examples

2.1.0

May 1, 2017

Updated

  • Replaced support for Bootstrap 4.0.0-alpha.4 with 4.0.0-alpha.6. #299 by tc-imba.

2.0.0

March 15, 2017

No changes to the package. Examples are updated. We're ONLY supporting:

    "extract-text-webpack-plugin": ">=2.1.0",
    "webpack": ">=2.2.0"

You might need to update these peer dependencies!

2.0.0

February 26, 2017

Fixed

  • Fix deprecated warning with loader-utils. #269 by ryani33.
  • Move lint dependencies to dev dependencies. #270 by ruiaraujo.

Added

  • Make bootstrap/bootstrap-sass path configurable so that it can be found when bootstrap-loader is symlinked in development. #255 by vjpr.

2.0.0

February 16, 2017

Updates

2.0.0

February 16, 2017

No changes

2.0.0

January 10, 2017

Fixed

  • Allow RC builds of webpack

2.0.0

December 15, 2016

Fixed

2.0.0

December 4, 2016

Added

  • Allow styleLoaders to depend on the environment variable NODE_ENV #222 by bertho-zero.

2.0.0

November 23, 2016

Fixed

  • Improved webpack performance. createUserImport should pass an absolute path to webpack.addDependency. #212 by stephanwilliams.

2.0.0

November 18, 2016

Added

  • Ensures -loader suffix automatically for style loaders to safely keep compatibility with old Webpack versions as well as new versions with the suffix requirement from Webpack v2.1.0-beta.26 and onward. #205 by kevinzwhuang.

2.0.0

November 14, 2016

Added

Support for multiple config files allowing both BS3 and BS4 in the same build. #195 by navarroaxel with help from judahmeek.

2.0.0

November 13, 2016

Nothing changed. Meant to include PR 195

2.0.0

October 3, 2016

Added

Support for disabling injection of SASS sourceMap or resolve-url-loader. #184 by judahmeek.

2.0.0

Changed

Support for Bootstrap 4.0.0-alpha.4. #167 by rmobis.

2.0.0

Includes all bug fixes for v1

2.0.0

Changes from v1.1.1 to 2.0.0.beta.2

1.1.6

September 8, 2016

Fixed

  • Allows chaining with some style loaders such as the isomorphic-style-loader. #98 by horyd.

1.1.5

September 7, 2016

Fixed

  • Fix for false could be interpretted as true for config file, scripts option #159 by justin808.

1.1.4

August 31, 2016

Fixed

Added

  • Support for Webpack v2.

1.1.3

August 30, 2016

Fixed

  • Fix for missing default params appStyles, preBootstrapCustomizations, and bootstrapCustomizations #151 by bmancini42

1.1.2

August 29, 2016

Fixed

1.1.1

August 28, 2016

Fixed

  • Only logging configuration file name if DEBUG is enabled.
  • Properly support both the DEBUG env variable so that it is something like TRUE, true, Yes, yes.

1.1.0

August 1, 2016

Added

1.0.10

March 17, 2016

Fixed

  • Fixes polyfill require for node < v4.0.0. #72 by mdgraser.

1.0.9

February 28, 2016

Fixed

  • Updated to support Bootstrap 4, Alpha 2, including examples. See #56 by justin808.

1.0.8