changelogs.md


wmfs/asl-choice-processor

Repository  -  API  -  Source

1.12.0

July 11, 2019

๐Ÿ›  Builds

  • deps: update lodash requirement from 4.17.11 to 4.17.14 (49f7d78)
  • deps-dev: update mocha requirement from 5.2.0 to 6.1.4 (fc273fd)
  • deps-dev: update nyc requirement from 13.2.0 to 14.1.1 (b02bdd4)
  • deps-dev: update semantic-release requirement (dae2ef2)

๐Ÿ“š Documentation

โš™๏ธ Continuous Integrations

  • circle: Add CircleCI config (475cae6)
  • travis: Remove Travis config (8a0cb8b)

1.11.0

February 8, 2019

๐Ÿ›  Builds

1.10.1

December 11, 2018

๐Ÿ› Bug Fixes

  • Choice processor would fail on undefined or null input (3d6e801)

๐Ÿ›  Builds

  • deps-dev: update semantic-release requirement (5be0b13)
  • deps-dev: update semantic-release requirement (037ce9b)
  • deps-dev: update semantic-release requirement (4e3d064)
  • deps-dev: update semantic-release requirement (0e437c7)
  • deps-dev: update semantic-release requirement (169b1e8)

1.10.0

November 3, 2018

๐Ÿ›  Builds

  • deps: update boom requirement from 7.2.1 to 7.2.2 (8288a3a)
  • deps-dev: update semantic-release requirement (8e40599)

1.9.0

November 1, 2018

๐Ÿ›  Builds

  • deps: update boom requirement from 7.2.0 to 7.2.1 (b2b4644)
  • deps-dev: update @semantic-release/changelog requirement (3b57947)
  • deps-dev: update @semantic-release/git requirement (3036878)
  • deps-dev: update nyc requirement from 13.0.1 to 13.1.0 (9de6499)
  • deps-dev: update semantic-release requirement (941decb)
  • deps-dev: update semantic-release requirement (bc2b54d)
  • deps-dev: update semantic-release requirement (1f06491)
  • deps-dev: update semantic-release requirement (bf00a16)

1.8.0

October 8, 2018

๐Ÿ›  Builds

  • deps: update debug requirement from 4.0.1 to 4.1.0 (f0e1e67)
  • deps-dev: update chai requirement from 4.1.2 to 4.2.0 (47ce78d)
  • deps-dev: update semantic-release requirement (666ea84)
  • deps-dev: update semantic-release requirement (1ab95ec)

1.7.0

September 12, 2018

๐Ÿ›  Builds

  • deps: update lodash requirement from 4.17.10 to 4.17.11 (0cc16b1)

1.6.0

September 11, 2018

๐Ÿ›  Builds

1.5.0

September 11, 2018

๐Ÿ›  Builds

  • deps: update debug requirement from 3.2.2 to 4.0.0 (b86323a)

1.4.0

September 11, 2018

๐Ÿ›  Builds

  • deps: update debug requirement from 3.2.1 to 3.2.2 (c084725)

1.3.0

September 11, 2018

๐Ÿ›  Builds

  • deps: update debug requirement from 3.1.0 to 3.2.1 (926442d)
  • deps-dev: update @semantic-release/git requirement from 7.0.1 to 7.0.2 (8dc2422)
  • deps-dev: update @semantic-release/git requirement from 7.0.2 to 7.0.3 (911d3a3)
  • deps-dev: update codecov requirement from 3.0.4 to 3.1.0 (dc47f11)
  • deps-dev: update nyc requirement from 12.0.2 to 13.0.1 (9e1cc85)
  • deps-dev: update semantic-release requirement (b763267)
  • deps-dev: update semantic-release requirement (f1984b0)
  • deps-dev: update semantic-release requirement from 15.9.11 to 15.9.12 (e994e6e)
  • deps-dev: update semantic-release requirement from 15.9.3 to 15.9.5 (20905e4)
  • deps-dev: update semantic-release requirement from 15.9.5 to 15.9.6 (4a4d88e)
  • deps-dev: update semantic-release requirement from 15.9.6 to 15.9.7 (bb7469f)
  • deps-dev: update semantic-release requirement from 15.9.7 to 15.9.8 (5ba8501)
  • deps-dev: update semantic-release requirement from 15.9.8 to 15.9.9 (aeadad1)
  • deps-dev: update semantic-release requirement from 15.9.9 to 15.9.11 (c34480e)
  • deps-dev: update semantic-release requirement to 15.9.1 (4ea7d25)
  • deps-dev: update semantic-release requirement to 15.9.2 (06b8413)
  • deps-dev: update semantic-release requirement to 15.9.3 (a1228dc)
  • dev-deps: Move to standard 12.0.1 (5e3a1e5)

โ™ป๏ธ Chores

  • codecov: 3.0.3 -> 3.0.4 (c8887bb)

1.2.0

July 19, 2018

โœจ Features

  • added isUndefined choice (31ebdbf)

๐Ÿ› Bug Fixes

๐Ÿ›  Builds

๐Ÿ“ฆ Code Refactoring

โš™๏ธ Continuous Integrations

  • .travis.yml: use travis_retry function (0ccf961)
  • package: add commit analyzer plugin config (50e70f8)
  • semantic-release: update devDependancy scope after change in Dependabot (61af1e2)
  • remove deps-dev scoping (cfcce81)